Table of Contents


ndOffice is an add-in for Microsoft Office - Word, Excel, PowerPoint, and Outlook - that allows users to open, edit, and save documents and emails without leaving the Office application.

Watch a brief ndOffice Tutorial Video (for version 1.5.5)

Download the ndOffice Quick Reference Guide (for version 1.6)

View the ndOffice feature highlight video (for version 1.6):


Supported in Office 2010 and 2013 – Word, Excel, PowerPoint, Outlook – on Windows 7+.

NOTE: The previous Office "Application Integrations" must be un-installed before ndOffice can be installed. Both programs cannot be installed together on the same machine, even if they are installed under different user profiles. 

To install ndOffice 1.6.10+, you must also have installed Microsoft’s .NET Framework 4.5.2 or higher and at least version 10.0.50903 of Visual Studio 2010 Tools for Office Runtime (VSTO). However, we strongly recommend you have at least VSTO 10.0.60724 and all available Windows Updates installed prior to installing ndOffice. Learn more at Updating ndOffice

Download ndOffice

Version 1.7.3 is now available. (see below)

The release of 1.7 is a limited release – it is not being pushed with the auto update. You need to manually download it from below.

This version is now supported in Office 2016. 

Download ndOffice ( (per user)

Download ndOffice ( (all users) 

NOTE: If you plan to have any of the ndOffice integrations (MacPac, DocXtools, etc.), then you MUST install the administrator's version (the All User install) which is linked at the bottom of this article. Keep in mind that if you install the All User version, you will not get automatic updates to ndOffice. 


Left & Right Panes

The left-hand navigation pane displays locations and containers in NetDocuments, while the right-hand pane will display workspace and folder contents, and search results.

These panes can be adjusted by dragging the divider to the left or right:


Additionally, the search box can also be adjusted:


Display Views

Select how you wish to display items in the right pane:


In the Details view, you can adjust the columns in the right-hand pane by sliding the column heading to the left or right.

When viewing a workspace, you can switch between the summary view and the list view:

Adding Folders

You can add a new folder as you save a document by clicking "Add Folder."

Opening Documents

You have access to all content normally available to you when accessing NetDocuments Online, including workspaces, folders, and Saved Searches. The only exception in the short term is ShareSpaces which are not currently accessible. ndOffice dialogs operate just like standard Office dialogs. For example, when viewing any file location, you will only see Word documents when opening from Word and Excel documents when opening from Excel. You can sort the columns, change the list view, size the right and left panes, and search.  

To open a document: 

1. Select File > Open.

2. Navigate to the desired document using the Navigation Pane, or run a search.

3. Click the document to open it in the current application.

Home Page

1. Click on or expand Home to view items on your Home Page.

2. Open a filing location (workspace, folder, etc.) in the left-hand navigation pane to access its contents.

3. Documents you have pinned to your Home Page will display in the right pane.

Recent Documents

1. Click Recent Documents to view all items you have recently accessed.


2. Expand Recent Documents to see lists that will display the 40 most recently Opened, Edited, or Added documents.

Recent Locations

1. Click Recent Locations to view the 10 most recent locations from which you have opened or to which you have saved items.



1. Select a cabinet in the left navigation pane for your search scope.

2. Select a search field next to the search box at the top right:

3. Enter keywords or phrases in the search box. Search results will display in the right-hand display pane.

Advanced Search

1. Click  adv_search.png  to use more advanced search features.

2. Use any combination of fields to narrow your search:

3. Go to NetDocuments Online for more searching features, such as searching for deleted items, and email messages. 


To access ndOffice Save functions, go to File > Save As in either Word, Excel, or PowerPoint.

You choose whether to browse to a filing location or ignore any specific location, even if a filing location was defaulted; OR profile only by changing the profile fields. You can also default the location to be the cabinet which will always require profiling, assuming the cabinet administration setting is set to not require “filing to a folder.”

At the top of the Open and Save dialogs there is an address bar, allowing the user to see the entire parent tree of the selected filing location, and allows clicking any parent level to go to that location.

The Save dialog will also show “Current Document” at the top of the Navigation tree below home. This represents your current document. If you uncheck "save as new version" you can easily re-profile your document or rename it.

Profile templates and security templates are accessible and encouraged for quick and easy profiling. Creating templates can only be done at ND online.

You can change the document’s file type by choosing from the drop down menu the options available in the Office application you are in.  A popular option to this feature is the ability to save a document as a PDF. To do this, you must be saving as a new version or a new document. 

NOTE: Office 2013 has the additional "backstage" dialog when opening or saving documents. This requires one extra click compared to Office 2010. You can bypass the backstage when using key commands by going to File > Options > Save and checking "Don't show the backstage when opening or saving files."

Create New Document

1. Open Word (or Excel or PowerPoint) and create your document.

2. Go to File > Save.

3. Select a NetDocuments location, or select a cabinet and complete the document’s profile instead of filing to a specific location. The filing location selected will display its inherited profiling information which will get applied to the new document. 


4. Continue editing or close your document.

NOTE: Clicking Save (or Ctrl+S) as you edit your document it will commit your changes to the NetDocuments Service.  

Save as a New Version

1. With your Word document open, select Save As.

2. By default, the Save as new version and Official version boxes will be checked.


3. Enter a description for the new version, then click OK.

4. Continue making edits, save, then close your document.

Save as a New Document (Copy)

1. With your Word document open, select File > Save As.

2. Uncheck the Save as new version option.


3. Select a new NetDocuments location.

4. Complete the profile, if applicable.

5. Continue editing or close your document.

Save as New Version of Existing Doc

1. Open a local document or an email attachment.

2. Go to File > Save As.


3. Select an existing document in NetDocuments.

4. Enter a description for the new version, then click OK.

5. Continue editing or close your document. 

NOTE: Saving a DOCX file will display only other DOCX files in the right pane. Change the Save as type field to see other files of the same type.

Version Management

You can open a specific version of a document by right-clicking on the document and selecting "Open a Version..."

Or, click Version Options to open the Versions dialog window. You can also open the version dialog box by left-clicking the version column of a document. 



ndOffice includes an add-in to perform Attach and File functions from within Outlook.

Attach File

Use the Attach File button to attach a copy of one or more documents to an email. One or more documents can be selected at a time or repeat the step to attach additional documents.


Using the versions dialog, users can attach a specific version. There is also an option to attach a comparison of the document from the document's list of attachments. 

Users may choose between adding a link, adding an attachment, or both at the same time:


Use the attachment option to email a copy of a document outside your firm. For use inside your firm, use the Insert as Link option.

Save an Email Message

1. Select one or more messages, then click ndSave:


2. The Save dialog also allows you to file multiple emails (and their attachments) to multiple locations.

You can choose to 1) select all msg files, 2) separate the body from the attachments, 3) save only attachments, and/or 4) manually select the desired items using the checkboxes.

You can also rename an msg file before saving by clicking the pencil icon.

3. Select the filing location. Click Save. You can save multiple messages to multiple locations before clicking Save and Close.

4. Click Save and Close when finished.


ndOffice settings are available from your Windows system tray:


Account Settings

Echo Folder and Backup Location

ndOffice includes a local cache of your most recent documents. This “echo” location can be found at C:\Users\<username>\ND Office Echo\VAULT-username.

A subfolder called backup is where documents are recovered if a document save was not successful.

To open the Echo folder, click the icon in the system tray then click View Echo Folder.

The echo settings located at ND online Settings > Workstation Settings will apply to the ndOffice echo folder, except for the location of the ndOffice echo folder. ndOffice determines the location of its echo folder and cannot be relocated.


Use the default option "prompt me for automatic updates" to receive automatic updates to ndOffice when they become available. We recommend using the latest version of ndOffice.  

Document ID Placement 

ndOffice provides four options for Microsoft Word documents regarding the location of the Document ID, under Settings: 

  • Footer of every page - The ID will be inserted in every footer. 
  • Footer of every page, except the first - The Id will be inserted on every footer, starting on the second page.
  • Last page - The ID will be inserted only on the very last page.
  • None - No ID will be inserted. 

Users also have the following option:

"Don't prompt me when applying ID stamp to documents."

This option, if unchecked, will prompt users to adjust their settings if they open a document that has a Doc ID in a place other than that specified in the setting above. 

Default Save and Open Locations

Settings also includes an option to set the default navigation location for the Open and Save dialogs.

For each app, choose the default Open (or Attach) and Save locations. 


Access the NetDocuments online Help by clicking on the Help link or visit the NetDocuments Support site at http://support.netdocuments.com.

Select Help > Report a Problem to 1) go to Support to submit a support ticket or review a knowledgebase article, or 2) view logs which the ND Support staff may request to be sent via email for problem resolution.  The logs are stored in ND Office Echo folder and if logs exist they will be named Echoingclient.log, WordAddin.log, PowerPointAddin.log and ExcelAddin.log.

Notification Windows

When a document has been successfully checked in or out, a system tray notification window will fade in for a few seconds and then fade out.  It will also highlight warnings if a document failed for some reason as ndOffice communicates with ND online.  

Opening documents from the Web

Documents opened and saved within ndOffice will be copied to the ndOffice echo location.  A document opened directly from ND in IE will be checked out through ndOffice. After edits are made, it will then be checked in through ndOffice as if it had been opened through ndOffice in the first place. This will allow users to have the Auto-Check In and version control features of ndOffice regardless of where the document is opened from. This will include accessing a document from a link received in an email. 

In this scenario, users will notice that when opening from the web, after the document is checked back in the green check mark will go away automatically!

When opening Word template documents, the template will not be checked out. Instead, it will just be placed into the Echo folder and opened from there. 

For Administrators

See our Software Installation Guide for more information.

ndOffice Adminstrative Setup (installs for All Users)

Caution: Do not point the ndOffice database to a temporary location or directory. Also, make sure that any virus scanner or firewall you have is excluding checking or accessing the ndOffice database. 


  • ndOffice is supported only in 32-bit Office. 
  • In order to use ndOffice in Outlook 2013, you must disable hardware graphics acceleration. Learn More
  • There is a known issue with Office 2010 and 2013 touchscreen environments when using ndOffice. Learn more
  • Excel's track changes feature is not currently supported in ndOffice. 

Back to Top

Was this article helpful?
3 out of 3 found this helpful


Have more questions? Submit a request