How to Update ndLink

Follow

Created:
Updated:

If you see "Error: The request was aborted: Could not create SSL/TLS secure channel" then you will need to update ndLink to fix this.

Below are the steps to update ndLink. 

NOTE: For the newer versions of ndLink you will need .NET Framework 4.6.1+ installed.

The update is easy and it will keep all of the prior settings and configurations.

Do the following in order:

  1. Update .NET to 4.6.1 or newer.
  2. Stop the ndLink service and exit the program.
  3. Locate the files for Ndlink2, specifically, look for the NDLink2_data folder.
  4. Create a backup of your current ndLink folder and contents.
  5. Uninstall the ndlinkservice from Programs and Features.
  6. Download the latest version of ndLink from the support site.
  7. Copy the contents of the downloaded ZIP over the top of the current files, copying and replacing them.
  8. Re-install the ndLink service by running setup.exe from the extracted files.
  9. Run ndLink as normal and it should be working. It should pick up all your configuration files, activities, SQL string etc., and should start itself. If it doesn't start itself, start it from the application.
  10. Delete or store the backed up copy of NDlink2_data. This is just to have as a backup in case something went awry, but its a good thing to stash somewhere on the server so you don't have to rebuild your activities or SQL string later on, if something were to happen to ndlink2, its files, or service.

 

If the update needs to be completed on Windows Server 2008 R2, you will often need to add the TLS protocols to the registry.

This link has a stepped process to do that: 

https://support.quovadisglobal.com/kb/a433/how-to-enable-tls-1_2-on-windows-server-2008-r2.aspx

As with any registry change, we highly recommend that you make a backup of your registry prior to any change. 

If you are not familiar with making registry changes or are uncomfortable doing so without guidance, please contact NetDocuments Support and we will assist you in making the necessary changes to update your version of ndlink2 to a TLS 1.1 compliant version.

Please keep in mind that you must have .NET Framework 4.6.1 or newer installed prior to calling Support.

 

Back to Top

Was this article helpful?
4 out of 4 found this helpful

Comments

Have more questions? Submit a request
Powered by Zendesk