Older versions of Acrobat, PDFs, and ndOffice

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The purpose of this article is to offer a work-around solution for firms experiencing issues checking in/out PDFs on older Acrobat software that is not supported by the current versions of ndOffice.

Issue/Problem

This problem is manifest most commonly when attempting to check in a PDF and the following window displays:

The next time you check out this document, you can be prompted with a window telling you that it is already checked out.

Cause

This is because the hand-off from the web to ndOffice does not support Adobe X. The hand-off still checks out the document, and ndOffice 'thinks' it is checked out, but ndOffice is unable to check the document back in. 

This 'hand-off' functionality must be manually disabled. It is not enough to simply uninstall the ndOffice-Adobe integration. This will allow pdf files to be checked out directly via the web UI, rather than ndOffice.

DISCLAIMER:

Officially we do not support Acrobat X (or Reader X). Only the latest release of ndOffice and Adobe Acrobat/Reader are supported. If you call in for help regarding older versions, the support team will do their best to assist, but may not be able to provide a solution to your problem if you are using these unsupported versions. 

Solution

If you are still using an older version of a unsupported PDF suite, this article will show you how to configure the pdf handoff to use the web controller instead of ndOffice when dealing with PDF documents. 

This is meant as a work-around and is not an officially supported function. Moreover, its meant to be a tip to help firms and companies that are not working with current versions of Adobe products. Please do not consider this a ‘cure-all’ for similarly manifested issues. 

Begin by opening your registry. Go to the Start menu and type regedit.exe

As with any registry change, we HIGHLY recommend that you make a copy of your registry in its current state before proceeding. If an accidental deletion or modification is made, this backup could mean the difference between a 10 minute restore and full system rebuild. Microsoft offers a walk through for that. Click HERE to see it.

This will look different in Windows 7 but the process is the same.  

It will open your computer registry:

Sometimes the registry opens behind everything else.  If you don’t immediately see the registry window, look for the blue cube icon on the task bar and click it to bring the registry to the front.

From here, navigate to these two areas:

Computer\HKEY_CURRENT_USER\Software\NetVoyage\NetDocuments

Computer\HKEY_LOCAL_MACHINE\Software\NetVoyage\NetDocuments

The ndOffice information should be stored in one of these two areas depending on how it was installed. You’ll recognize it because you’ll see the ndOfficeHandoff entry there:

 

If you can’t find this in either of those two paths call Tier 1 Support: 1.866.638.3627 opt 2. We will give you hand finding this.

Double-click on the ndOfficeHandoff line. It will give you a small window with the value data:

Delete everything in the value data and click OK.

You should no longer see anything on that line in the data column:

 

Close the registry with the red X in the top right and restart ndOffice and the browser.

When you restart the browser and ndOffice, when you check out pdfs, you should see this icon in the top right corner of the browser window:

This means that the item was not checked out with ndOffice, instead, using whatever browser plugin you have set for PDFs (Adobe, Nuance, eCopy etc).

When you are done with the pdf, click this icon again or either of the matching two green checkmarks on the document icon or in the details pane, and the item should check back in without having to force check in the document. 

If this fails at any point, call us in Support and we’ll lend a hand.  

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