ndOneClick users being prompted to "Open ndOneClick" repeatedly with a recent Chrome update.

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Updated:

NetDocuments recommends using ndClick application instead of ndOneClick for better performance and functionality. See ndClick.

Problem
Users are being presented with the following prompt on every page or document open.

 mceclip0.png

Environment
Chrome Browser 77.0.3864+
ndOneClick protocol handler 

Cause
Chrome 77.0.3864 removed the “Always open these types of links in the associated app” checkbox and the update has removed the trust that users previously provided to ndOneClick.

Resolution
Where possible users should upgrade to ndClick as the browser integration software for the future. 

At the time of writing ndClick is not supported in multi-user environments like Citrix or RDS though release of ndClick 1.3 with this support is expected soon. 

For those multi users sites with ndOneClick it appears the only options presently are to;

Work around: You can manually fix this issue in Chrome until the update from Google is released.

1. Close Chrome completely, you may need to check Task Manager to ensure it is not running.

2. Browse to %localappdata%\Google\Chrome\User Data\Default\ and open the Preferences file. 

Please note the file has no extension, it will prompt you to choose an appropriate program to open it with and Notepad is fine for this.

3. Search for excluded_schemes by clicking CTRL + F or using the Edit, Find menu.

You should find that looks similar to the following example

update the entry

"protocol_handler":{"excluded_schemes":{}}

with

"nd":false between the curly braces. 

e.g. "protocol_handler":{"excluded_schemes":{"nd":false}}

if there are other entries, append the entry 

e.g. "protocol_handler":{"excluded_schemes":{"someothersoftware":false,"nd":false}}

being careful not to make any other changes to existing entries. 

Save the file. 

Restart Chrome and test that you are no longer prompted when clicking on files in NetDocuments.

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