ndMail Error Handling
ndMail communicates with the NetDocuments servers via a secured SSL connection to prevent inadvertent data loss. Certain errors may occur during the communication process due to:
- Local Internet failures
- Slow responses or no responses at all from the intermediate Internet gateways
- Errors returned from the NetDocuments servers
Error messages are intended to communicate a cause and resolution of a problem that might have occurred.
No Internet Connection or No Connection to NetDocuments (502-504 error)
Cause |
This notification appears when you are logged in to NetDocuments, but there is no Internet connection or when there is no connection to NetDocuments. |
Resolution |
When you restore your connection, try again. If the error message appears again, submit a support request including a trace log of the failure and the time this error has occurred. |
No Connection to Exchange Server
Cause |
This error message appears when there is no connection to Microsoft Exchange Server. |
Resolution |
When you restore your connection, try again. If the error message appears again, you need to contact an administrator or submit a support request including a trace log of the failure and the time this error has occurred. |
Internal Server Error or an Error in Getting Predictions Call
Cause |
This notification appears when the issue happens on the server or on getting the predictions call. |
Resolution |
When you restore your connection, try again. If the error message appears again, you need to contact an administrator or submit a support request including a trace log of the failure and the time this error has occurred. |
No Cabinet Available
Cause |
This notification appears when there are no cabinets available as there is no active repository. |
Resolution |
To resolve this issue, you need to contact the administrator. |
No Data to Generate Predictions
Cause |
This notification appears when there are no predicted filing locations. |
Resolution |
To find a filing location, you need to click the browse link or the Browse button. |
Search Criteria Cannot Find Matching Results
Cause |
This notification appears when ndMail returns no results matching the search criteria. |
Resolution |
To find a filing location, you need to refine their search criteria or click the browse link (or the Browse button). |
Search: Server is not Accessible during OR with No Internet Connection
Cause |
This notification appears when there is no connection to the server. |
Resolution |
To resolve this issue, you need to contact the administrator. |
Logging and How It Works
Log |
Description |
---|---|
ndMailApplication.log |
Log exceptions that occur in the ndMail application that includes exceptions’ stack traces. These logs are always system-created, and they do not depend on user’s settings. |
ndMailOutlookAddIn.log |
Log exceptions that occur in the ndMail Outlook add-in that includes exceptions’ stack traces. These logs are always system-created, and they do not depend on user’s settings. |
ndMailOutlookAddInTrace.log |
Tracing logs in the ndMail Outlook add-in. These logs include time of execution, duration, and method parameters of the add-in. These logs depend on the TracingEnabled registry. (HKEY_CURRENT_USER\SOFTWARE\NetDocuments\ndMail). The default value is False. Users need to modify it to True. |
ndMailApplicationTrace.log |
Tracing logs in the ndMail application. These logs include time of execution, duration, and method parameters of Tray Application. These logs depend on the TracingEnabled registry. (HKEY_CURRENT_USER\SOFTWARE\NetDocuments\ ndMail). The default value is False. Modify it to True. |
ndMailApplicationRESTApiTrace.log |
REST API trace – logs interactions with REST API. Shows request, response, time, duration, and request parameters. These logs depend on the RestTracingEnabled registry. (HKEY_CURRENT_USER\SOFTWARE\NetDocuments\ndMail). The default value is False. Users need to modify it to True. |
ndMailApplicationJournal.log |
Logs that have information about the start/stop/connection lost/restored activities. Also, include key operations like email filing started, email filing finished, and so on. |