ndOffice

Follow

Created:
Updated:

  • OS: Windows 7, 8, & 10
  • Browser: N/A
  • Office: 2010, 2013, 2016

Table of Contents

Introduction

ndOffice is an add-in for Microsoft Office - Word, Excel, PowerPoint, and Outlook - that allows users to open, edit, and save documents and emails without leaving the Office application. 

Download the ndOffice Quick Reference Guide (for version 2.1)

Requirements:

ndOffice is supported in Office 2010 (SP2), 2013, and 2016 – Word, Excel, PowerPoint, Outlook – on Windows 7+.

ndOffice version 1.8+ is supported in Office 2013 and 2016, both 32-bit and 64-bit. It is supported in only 32-bit Office 2010.

See all ndOffice System Requirements

We strongly recommend you have all available Windows Updates installed prior to installing ndOffice.

Download ndOffice

Current version: 2.1.19.9119. See what is new in ndOffice 2.1.

Linked below are both the .exe and .msi download options. Each are all-user installs and will install version 2.1. The .exe version is used when ndOffice is installed via auto-update, and is also a "bootstrapper" capable of also installing the required versions of VSTO and .NET., and will also uninstall any previous per-user installs of ndOffice 1.8+. 

Make sure you have the most up-to-date version of ndOffice available (previous versions are no longer supported):

Service .exe .msi
Vault (US) Download Download 
EU Download Download
AU Download Download

Adobe Integration

With ndOffice 1.8+ an integration with Adobe Reader and Adobe Acrobat is included. The add-in will be installed automatically if Adobe XI or Adobe DC is detected on the computer. The add-in is only supported in these versions.  

Learn more about ndOffice for Adobe

The option to install the Adobe integration is currently only available when installing ndOffice via the All Users install package using the Advanced install options. 

IP / Court Filing

ndOffice 1.9.2+ also allows for filing to IP or Court websites. Learn more about IP/Court Filing

HOW DO I USE ndOFFICE?

The Activity Center helps you keep track of all your activity in ndOffice, across all apps. The Activity Center pops up from the Windows tray when you click the ndOffice icon: 

Click a document to open it.

The Activity Center includes:

  • Progress bar as a document downloads or uploads
  • List of up to the last 100 documents you accessed via ndOffice
  • Icons readily identify each type of document, including emails. 
  • Documents are presented in collapsible groups by:
    • Today
    • Yesterday
    • Last Week
    • Older than Two Weeks
  • Status is shown for documents that are:
    • Opened for editing
    • Checked in (with date / time)

Information Panel

Each document in the list also includes an Info button. This opens the new document information panel:

The Information panel includes:

  • Document ID
  • Version info
  • File type
  • Created by/date
  • Modified by/date
  • Ability to edit version description
  • Profile information (custom metadata)

Right-Click Menu

The Activity Center also includes a right-click menu for items in the list:

ac_right-click.png

These options include:

  • Open
  • Open as read only
  • Open as new document
  • Open as new version
  • Rename
  • Print
  • Get Link
  • Version and attachment options

In the Open dialog, the right-click menu includes the same options.  

Left & Right Panes

The left-hand navigation pane displays locations and containers in NetDocuments, while the right-hand pane will display workspace and folder contents, and search results.

These panes can be adjusted by dragging the divider to the left or right:

adjust_right_pane.png

Additionally, the search box can also be adjusted:

adjust_search_box.png

Display Views

Select how you wish to display items in the right pane:

icon_display_button.png

In the Details view, you can adjust the columns in the right-hand pane by sliding the column heading to the left or right.

When viewing a workspace, you can switch between the summary view and the list view:

Adding Folders

You can add a new folder as you save a document by clicking "Add Folder."

Adding Workspaces

When saving documents or email messages, users can add a workspace to their Favorites list:

Opening Documents

You have access to all content normally available to you when accessing NetDocuments Online, including workspaces, folders, and Saved Searches. The only exception in the short term is ShareSpaces which are not currently accessible. ndOffice dialogs operate similar to the standard Office dialogs. For example, when viewing any file location, you will only see Word documents when opening from Word and Excel documents when opening from Excel. You can sort the columns, change the list view, size the right and left panes, and search.  

To open a document: 

1. Select File > Open.

2. Navigate to the desired document using the Navigation Pane, or run a search.

3. Click the document to open it in the current application.

Home Page

1. Click on or expand Home to view items on your Home Page.

2. Open a filing location (workspace, folder, etc.) in the left-hand navigation pane to access its contents.

3. Documents you have pinned to your Home Page will display in the right pane.

NOTE: Workspaces on the Home Page are cached for 30 seconds, and documents are cached for 30 minutes. This means some users may see delays when adding Favorites to their Home Page from the web UI.

Recent Documents

1. Click Recent Documents to view all items you have recently accessed.

open_recent.png

2. Expand Recent Documents to see lists that will display the 40 most recently Opened, Edited, or Added documents.

Recent Locations

1. Click Recent Locations to view the 10 most recent locations from which you have opened or to which you have saved items.

 recent_locations.png

Searching

1. Select a cabinet in the left navigation pane for your search scope.

2. Select a search field next to the search box at the top right:

3. Enter keywords or phrases in the search box. Search results will display in the right-hand display pane.

Advanced Search

1. Click  adv_search.png  to use more advanced search features.

2. Use any combination of fields to narrow your search:

3. Go to NetDocuments Online for more searching features, such as searching for deleted items, and email messages. 

SAVING DOCUMENTS

To access ndOffice Save functions, go to File > Save As in either Word, Excel, or PowerPoint.

You choose whether to browse to a filing location or ignore any specific location, even if a filing location was defaulted; OR profile only by changing the profile fields. You can also default the location to be the cabinet which will always require profiling, assuming the cabinet administration setting is set to not require “filing to a folder.”

At the top of the Open and Save dialog windows there is an address bar, allowing the user to see the entire parent tree of the selected filing location, and allows clicking any parent level to go to that location.

The Save dialog will also show “Current Document” at the top of the Navigation tree below home. This represents your current document. If you uncheck "save as new version" you can easily re-profile your document or rename it.

Profile templates and security templates are accessible and encouraged for quick and easy profiling. Creating templates can only be done at ND online.

NOTE: When applying the Private security template, if you select this template, then select an Author value that is linked to a user, you will see an error message. This is intended behavior because adding the linked Author conflicts with the Private security template. You cannot add a user to the ACL of a document marked as Private. 

You can change the document’s file extension by choosing from the drop down menu the options available in the Office application you are in. A popular option to this feature is the ability to save a document as a PDF. To do this, you must be saving as a new version or a new document. 

NOTE: Office 2013 has the additional "backstage" dialog when opening or saving documents. This requires one extra click compared to Office 2010. You can bypass the backstage when using key commands by going to File > Options > Save and checking "Don't show the backstage when opening or saving files."

Create New Document

1. Open Word (or Excel or PowerPoint) and create your document.

2. Go to File > Save.

3. Select a NetDocuments location, or select a cabinet and complete the document’s profile instead of filing to a specific location. 

The filing location selected will display its inherited profiling information which will get applied to the new document. 

save_as_new_doc.png

4. Continue editing or close your document.

NOTE: Clicking Save (or Ctrl+S) as you edit your document will commit your changes to the NetDocuments Service.  

Save as a New Version

1. With your Word document open, select Save As.

2. By default, the Save as new version and Official version boxes will be checked.

save_as_new_version.png

3. Enter a description for the new version, then click OK.

4. Continue making edits, save, then close your document.

Save as a New Document (Copy)

1. With your Word document open, select File > Save As.

2. Uncheck the Save as new version option.

save_new_doc.png

3. Select a new NetDocuments location.

4. Complete the profile, if applicable.

5. Continue editing or close your document.

Save as New Version of Existing Doc

1. Open a local document or an email attachment.

2. Go to File > Save As.

save_as_version_of_existing_doc.png

3. Select an existing document in NetDocuments.

4. Enter a description for the new version, then click OK.

5. Continue editing or close your document. 

NOTE: Saving a DOCX file will display only other DOCX files in the right pane. Change the Save as type field to see other files of the same type.

Profile fields are color-coded:

Blue = Optional, Empty
Red = Required, Empty (required fields still have an asterisk beside them).
Green = Filled out

Version Management

You can open a specific version of a document by right-clicking on the document and selecting "Open a Version..."

Or, click Version Options to open the Versions dialog window. You can also open the version dialog box by left-clicking the document's version number in the version column. 

Version_dialog.png
 

ND Compare

By leveraging Word's compare features, you can compare two documents – either documents in NetDocuments (separate documents or versions) and/or documents on a local file system.

nd_compare_button.png

Select the documents to compare:

compare_dialog.png

Word's built-in comparison functions will then be launched. 

After comparing, you can put the result back as an attachment to the document you compared, as a version of a document, or as a new separate document (of any type).

When finished, note the “Save as Attachment” option on the review dialog.

MANAGING EMAIL

ndOffice includes an add-in to perform Attach and Save/File functions from within Outlook.

Compare ndOffice for Outlook with EMS Profiler

Attach File

Use the Attach File button to attach a copy of one or more documents to an email. One or more documents can be selected at a time or repeat the step to attach additional documents.

ndattach.png

Using the versions dialog, users can attach a specific version. There is also an option to attach a comparison of the document from the document's list of attachments. 

Users may choose between adding a link, adding an attachment, or both at the same time:

insert_Outlook.png

Use the attachment option to email a copy of a document outside your firm. For use inside your firm, use the Insert as Link option.
 
Editing Attachments
 
When attaching documents, users can edit the order of attachments, as well as the name of the attachments before sending them:

The user will also have options to zip attachments and convert attachments to PDF before sending.

Users will be able to cancel large attachments while they download.

Save an Email Message

1. Select one or more messages, then click ndSave:

 ndsave_Outlook.png

2. The Save dialog also allows you to file multiple emails (and their attachments) to multiple locations.

You can choose to 1) select all msg files, 2) separate the body from the attachments, 3) save only attachments, and/or 4) manually select the desired items using the checkboxes.

You can also rename an msg file before saving by clicking the pencil icon next to the message name:

3. Select the filing location. Click Save. You can save multiple messages to multiple locations before clicking Save and Close.

4. Click Save and Close when finished.

Suggested Locations

In Outlook's Home tab, users will see the ND Save button. A list of suggested filing locations will be available, with the top item displayed. 

The ndOffice toolbar provides suggested file locations based on previous filing locations for that sender. Simply click the listed location to file the email to that location, or select from the list of other suggestions. 

You can easily profile to a client/matter without having to open the ndOffice dialogs. If the item isn’t in the ten locations shown by default (associated with an email address) then clicking the Select Workspace option will open a pane (not the entire dialog), your cursor will be placed in the Client field and you can begin profiling. You can also change the cabinet here.

suggested_locations.png

A new column called "ND Location" is added to the user's Outlook view that displays the filed email's location.

When filing email messages, users will have the option to apply "Private Access" to an email. This removes all users' access to the message but retains VESA rights for the user who files the message.

Send & File

Users will have a checkbox in settings to enable Outlook Send & File. The Send & File button can be used to save a new email message (or a reply to a received message) while it is being sent.

Users who uncheck the "prompt to file outgoing messages" option will see two buttons - "Send & File" and "Send Only" for new email messages.

Depending on whether you have this option on or off, there are buttons to override that behavior in Outlook. So, if the option is ON, clicking Send will do a Send-and-File, and clicking Send Only on the ribbon will override that behavior. If the option is OFF, clicking Send does a normal Send Only, and clicking Send & File overrides that behavior.

The Send & File dialog will not display when responding to calendar invitations.

Save an Email Attachment

1. Right-click an individual attachment and choose Save to NetDocuments.

Attach to Calendar Event

Users can attach items to a calendar event in Outlook. This opens the standard Attach dialog, which allows the user to select one or more items to attach.

attach_doc_to_meeting.png

Offline Mode

We’re working on improving the offline capabilities of ndOffice. In Phase 1, delivered in 2.1, we will watch to see if you lose your internet connection (or, your connection to NetDocuments) and, depending on your registry settings, alert you to the fact you’re offline and that edits will be saved to NetDocuments when the connection is restored.

Additionally, if there are errors from NetDocuments when working with a document, rather than a complete failure, we’ll show the dialog but show inline connection messages because of a connection issue, or some problem with the service. And you’ll be able to open documents from the echo, edit them, and they will be restored when you get a connection again.

In version 2.2 later this year, ndOffice will also have the ability to “hit the road” taking documents with you, and to create new documents while disconnected for later completion.

SETTINGS & HELP

ndOffice settings are available from the Activity Center:

Account Settings

Echo Folder and Backup Location

ndOffice includes a local cache of your most recent documents. This “echo” location can be found at C:\Users\<username>\ND Office Echo\SERVICE-username.

A subfolder called backup is where documents are recovered if a document save was not successful.

To open the Echo folder, click the icon in the system tray then click View Echo Folder.

The echo settings located at ND online Settings > Workstation Settings will apply to the ndOffice echo folder, except for the location of the ndOffice echo folder. ndOffice determines the location of its echo folder and cannot be relocated.

Updates

Use the default option "prompt me for automatic updates" to receive automatic updates to ndOffice when they become available. We recommend using the latest version of ndOffice.  

Document ID Placement 

ndOffice provides four options for Microsoft Word documents regarding the location of the Document ID, under Settings: 

  • Footer of every page - The ID will be inserted in every footer. 
  • Footer of every page, except the first - The Id will be inserted on every footer, starting on the second page.
  • Last page - The ID will be inserted only on the very last page.
  • None - No ID will be inserted. 

Users also have the following option:

"Don't prompt me when applying ID stamp to documents."

This option, if unchecked, will prompt users to adjust their settings if they open a document that has a Doc ID in a place other than that specified in the setting above. 

Default Save and Open Locations

Settings also includes an option to set the default navigation location for the Open and Save dialogs.

For each app, choose the default Open (or Attach) and Save locations: 

For Outlook:

Columns

Users can specify additional columns like client, matter, author, and so forth, for the Save and Open dialogs. Users can now specify up to 9 attributes and determine what order they occur in. Name always stays first in the list. 

Other

This tab allows users to configure the Send & File button in Outlook, as well as the number of items to display in the Activity Center.

Help

Access the NetDocuments online Help by clicking on the Help link or visit the NetDocuments Support site at http://support.netdocuments.com.

Select Help > Report a Problem to...

1) go to the Support Site to submit a support ticket or review a knowledgebase article, or

2) view logs which the ND Support staff may request to be sent via email for problem resolution. The logs are stored in ND Office Echo folder and if logs exist they will be named Echoingclient.log, WordAddin.log, PowerPointAddin.log and ExcelAddin.log.

Notification Windows

When a document has been successfully checked in or out, a system tray notification window will fade in for a few seconds and then fade out. It will also highlight warnings if a document failed for some reason as ndOffice communicates with ND online.  

Opening documents from the Web

Documents opened and saved within ndOffice will be copied to the ndOffice echo location. A document opened directly from ND in IE will be checked out through ndOffice. After edits are made, it will then be checked in through ndOffice as if it had been opened through ndOffice in the first place. This will allow users to have the Auto-Check In and version control features of ndOffice regardless of where the document is opened from. This will include accessing a document from a link received in an email. 

In this scenario, users will notice that when opening from the web, after the document is checked back in the green check mark will go away automatically!

When opening Word template documents, the template will not be checked out. Instead, it will just be placed into the Echo folder and opened from there.  

For Administrators

Below is information pertinent to system administrators and IT engineers. 

Caution: Do not point the ndOffice database to a temporary location or directory. Also, make sure that any virus scanner or firewall you have is excluding checking or accessing the ndOffice database. 

See our ndOffice Workflow Diagrams to learn more about how ndOffice operates.

Refer to our ndOffice Technical Overview (for version 2.1) for more detailed information.

See our Software Installation Guide for more information, such as registry keys and command line switches. 

ndOffice 2.0 includes additional email filing capabilities that overlap with EMS Profiler (and EM as well), but it is not feature-complete with EMS Profiler.

Compare ndOffice for Outlook with EMS Profiler

When ndOffice 2.1 is available users may decide to remove EMS Profiler. A replacement for EMS Folders will eventually also be made available. 

Learn more about disabling ndOffice features in Outlook

NOTES

  • Version 1.7.4+ is supported in Office 2013 /2016 on 64 bit or 32-bit.
  • In order to use ndOffice in Outlook 2013, you must disable hardware graphics acceleration. Learn More
  • There is a known issue with Office 2010 and 2013 touchscreen environments when using ndOffice. Learn more
  • Excel's track changes feature is not currently supported in ndOffice. 

Back to Top

Was this article helpful?
4 out of 4 found this helpful

Comments

Have more questions? Submit a request
Powered by Zendesk